- Router Eigrp Redistribute Connected
- Router Eigrp Redistribute Static Friction
- Router Eigrp 100 Redistribute Static
The problem is that, without inserting the redistribute static command under the router eigrp command in Router B, Router B automatically redistributes all the 127 static routes configured to Router A. This can cause unnecessary routes being advertised inadvertently throughout the entire network.
This posting is going to cover an interesting topic - redistribution and specifically redistribution of static routes into EIGRP. Now before you skip the post, we're going to cover how you can make static routes appear as if they are internal to EIGRP.- Timigate Cisco, EIGRP, Redistribution, Static route Route redistribution is a great way to share routes between routers running different routing protocols or routers running the same dynamic routing protocol but in different autonomous systems.
- You can inject static routes into EIGRP two ways: The 'network' command 'redistribute static' You only need one or the other; here you've used both. It seems that the redistribution command takes precedence over the network command so the route is appearing as static routes. Remove 'redistribute static' and the route should appear as internal.
interface Loopback0
ip address 10.1.1.0 255.255.255.255
!
Router Eigrp Redistribute Connected
interface Loopback1ip address 10.1.1.1 255.255.255.255
!
interface Loopback2
ip address 10.1.1.2 255.255.255.255
!
interface Loopback3
ip address 10.1.1.3 255.255.255.255
!
interface Serial0/0
ip address 10.1.12.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 10.1.12.2 102 broadcast
no frame-relay inverse-arp
!
ip route 0.0.0.0 0.0.0.0 10.1.12.2
R2
hostname R2
interface Serial0/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial0/0.21 point-to-point
ip address 10.1.12.2 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 201
!
interface Serial0/0.23 point-to-point
ip address 10.1.23.2 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 203
!
router eigrp 23
redistribute static metric 1 1 1 1 1
network 10.1.23.2 0.0.0.0
no auto-summary
!
ip route 10.1.1.0 255.255.255.255 10.1.12.1
ip route 10.1.1.1 255.255.255.255 10.1.12.1
ip route 10.1.1.2 255.255.255.255 10.1.12.1
ip route 10.1.1.3 255.255.255.255 10.1.12.1
R3
Router Eigrp Redistribute Static Friction
interface Serial0/0ip address 10.1.23.3 255.255.255.0
encapsulation frame-relay
Router Eigrp 100 Redistribute Static
frame-relay map ip 10.1.23.2 302 broadcast
no frame-relay inverse-arp
!
router eigrp 23
network 10.1.23.3 0.0.0.0
no auto-summary
!
Ok, so nothing special so far, lets have look at what's in the EIGRP topology table:
R2#sh ip eigrp topology
IP-EIGRP Topology Table for AS(23)/ID(10.1.23.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.1.1.2/32, 1 successors, FD is 2560000256
via Rstatic (2560000256/0)
P 10.1.1.3/32, 1 successors, FD is 2560000256
via Rstatic (2560000256/0)
P 10.1.1.0/32, 1 successors, FD is 2560000256
via Rstatic (2560000256/0)
P 10.1.1.1/32, 1 successors, FD is 2560000256
via Rstatic (2560000256/0)
P 10.1.23.0/24, 1 successors, FD is 2169856
via Connected, Serial0/0.23
R2#sh ip eigrp topology 10.1.1.0/32
IP-EIGRP (AS 23): Topology entry for 10.1.1.0/32
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
Routing Descriptor Blocks:
10.1.12.1, from Rstatic, Send flag is 0x0
Composite metric is (2560000256/0), Route is External
Vector metric:
Minimum bandwidth is 1 Kbit
Total delay is 10 microseconds
Reliability is 1/255
Load is 1/255
Minimum MTU is 1
Hop count is 0
External data:
Originating router is 10.1.23.2 (this system)
AS number of route is 0
Administrator tag is 0 (0x00000000)
This is all normal, static routes redistributed to into EIGRP are external routes..
R3#sh ip route | b Gateway
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D EX 10.1.1.2/32 [170/2560512256] via 10.1.23.2, 00:03:05, Serial0/0
D EX 10.1.1.3/32 [170/2560512256] via 10.1.23.2, 00:03:05, Serial0/0
D EX 10.1.1.0/32 [170/2560512256] via 10.1.23.2, 00:03:05, Serial0/0
D EX 10.1.1.1/32 [170/2560512256] via 10.1.23.2, 00:03:05, Serial0/0
C 10.1.23.0/24 is directly connected, Serial0/0
So as I mentioned earlier we can actually make these static routes appear as internal to EIGRP but to make it happen we need to follow a few rules to make it work:
1) The static routes must use an interface as the next-hop rather than an using the next-hop IP Address:
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#no ip route 10.1.1.0 255.255.255.255 10.1.12.1
R2(config)#ip route 10.1.1.0 255.255.255.255 s0/0.21
R2(config)#no ip route 10.1.1.1 255.255.255.255 10.1.12.1
R2(config)#ip route 10.1.1.1 255.255.255.255 s0/0.21
R2(config)#no ip route 10.1.1.2 255.255.255.255 10.1.12.1
R2(config)#ip route 10.1.1.2 255.255.255.255 s0/0.21
R2(config)#no ip route 10.1.1.3 255.255.255.255 10.1.12.1
R2(config)#ip route 10.1.1.3 255.255.255.255 s0/0.21
Update: 31 March 2012 - Tom Kacprzynski rightly informed me that step 2 is not actually required at all for this procedure to work. Thanks Tom!
3) Include the networks of the static routes into EIGRP
R2(config-router)#network 10.1.1.0 0.0.0.3
R2(config-router)#end
Now to see what has changed:
R2#show ip route | b Gateway
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 10.1.12.0/24 is directly connected, Serial0/0.21
S 10.1.1.2/32 is directly connected, Serial0/0.21
S 10.1.1.3/32 is directly connected, Serial0/0.21
S 10.1.1.0/32 is directly connected, Serial0/0.21
S 10.1.1.1/32 is directly connected, Serial0/0.21
C 10.1.23.0/24 is directly connected, Serial0/0.23
These are still definitely static routes, what about the EIGRP topology?
R2#sh ip eigrp topology 10.1.1.0/32
IP-EIGRP (AS 23): Topology entry for 10.1.1.0/32
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
Routing Descriptor Blocks:
0.0.0.0, from Rstatic, Send flag is 0x0
Composite metric is (2560000256/0), Route is Internal
Vector metric:
Minimum bandwidth is 1 Kbit
Total delay is 10 microseconds
Reliability is 1/255
Load is 1/255
Minimum MTU is 1
Hop count is 0
It is now showing up as an internal route even though it shows it was redistributed from static, what does our EIGRP peer R3 see?
R3#show ip route | b Gateway
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D 10.1.12.0/24 [90/2681856] via 10.1.23.2, 00:02:55, Serial0/0
D 10.1.1.2/32 [90/2560512256] via 10.1.23.2, 00:02:55, Serial0/0
D 10.1.1.3/32 [90/2560512256] via 10.1.23.2, 00:02:55, Serial0/0
D 10.1.1.0/32 [90/2560512256] via 10.1.23.2, 00:02:55, Serial0/0
D 10.1.1.1/32 [90/2560512256] via 10.1.23.2, 00:02:55, Serial0/0
C 10.1.23.0/24 is directly connected, Serial0/0
R3#sh ip eigrp topology 10.1.1.0/32
IP-EIGRP (AS 23): Topology entry for 10.1.1.0/32
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560512256
Routing Descriptor Blocks:
10.1.23.2 (Serial0/0), from 10.1.23.2, Send flag is 0x0
Composite metric is (2560512256/2560000256), Route is Internal
Vector metric:
Minimum bandwidth is 1 Kbit
Total delay is 20010 microseconds
Reliability is 1/255
Load is 1/255
Minimum MTU is 1
Hop count is 1
Yes, those static routes on R2 appear to R3 as if they are internal EIGRP routes. Actually, we can remove the 'redistribute static' from the EIGRP process as it is no longer required in this instance.
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router eigrp 23
R2(config-router)#no redistribute static
R2(config-router)#end
Strange as it seems, this appears to be a design intent for EIGRP and is documented on Cisco's website about this.
Mututal redistribution is commonly done to fix architectural problems or during company acquisitions. This lab will discuss and demonstrate the configuration and verification of mutual EIGRP and RIP redistribution.
Real World Application & Core Knowledge
If you've completed Lab 10-2 – Configuring Mutual OSPF and RIP Redistribution and Lab 10-3 – Configuring Mutual OSPF and EIGRP Redistribution then you should be no stranger to mutual route redistribution.
If you did not complete the previous labs then to summarize mutual route redistribution up in a pretty little nut shell; mutual route redistribution is the process where two dynamic routing protocols exchange their routes with each other. For example, When you redistribute EIGRP into RIP, all routes in the EIGRP Autonomous System will be injected into the RIP database and show up as regular RIP routes. The same concepts apply to EIGRP when you redistribute RIP into EIGRP, all the routes from RIP will be injected into the EIGRP topology table and advertised through out the autonomous system as an EIGRP External route. These routes are denoted as 'D EX' routes in the routing table.
Mutual route redistribution is a common remedy when companies acquire other companies that use different routing protocols. In such case Company ABC Inc. acquires Company XYZ Inc. however ABC Inc. uses EIGRP and XYZ Inc. uses RIP. After the acquisition, the CTO (Chief Technology Officer) Mandates that there be full network communication between the newly merged companies. In this case you'd need to perform mutual redistribution to ensure ABC Inc. has routes to XYZ's network; vice-versa.
When you configure mutual route redistribution its best practice to specify a static metric. When specifying a metric keep in mind if you have multiple routers performing mutual redistribution you may need to have a higher metric on one router then the other to prevent a routing loop; this is where packets just keep going in circles between the two autonomous systems. It's a safe bet to specify a fairly high metric in a production network to prevent such routes from becoming looped as lower metric routes are preferred.
The original pitch and time correction audio plugin for finely-tuned vocal pitches. Snap mac screen. GSnap is a very powerful tool given that it?s free. All you need is a monophonic input signal (a microphone can be used) and this software can auto-tune the sound. This can be done to a small degree helping you to correct your pitch or you can ramp it up to create a robotic sound.
We do not provide paid / free Hello Darling Movie downloads. We do not offer to watch Hello Darling movie online. Hello Darling Movie Review are added by registered customers. Free wallpapers download of Hello Darling movie, hero, heroine, etc is available in our Gallery section. Full length feature film shot totally in the Midlands of the UK. Excellent cast and very enthusiastic and able Production Team and Crew. Lots of friends pitched in as. Hello darling full movie watch online, free putlocker. Watch Darling Full Movie by TeluguJosh on dailymotion. Darling Full Movie. 3 videos Updated 2 years ago. Sweetheart - Part 11/11. Sweetheart - Part 10/11. Sweetheart - Part 09/11. About Us What's New Help Center Jobs API Become a. Watch your favourite shows from Star Plus, Star World, Life OK, Star Jalsha, Star Vijay, Star Pravah, Asianet, Maa TV & more online on Disney+ Hotstar. Download Darling Darling movie (1977) to your Hungama account. Watch Darling Darling movie full online. Check out full movie Darling Darling download, movies counter, new online movies in Hindi and more latest movies at Hungama. Download Hungama Play app to get access to new unlimited free mp4 movies download, boolywood movies 2019/2018/2017, latest music videos, kids movies, Hungama.
interface Loopback0
ip address 10.1.1.0 255.255.255.255
!
Router Eigrp Redistribute Connected
interface Loopback1ip address 10.1.1.1 255.255.255.255
!
interface Loopback2
ip address 10.1.1.2 255.255.255.255
!
interface Loopback3
ip address 10.1.1.3 255.255.255.255
!
interface Serial0/0
ip address 10.1.12.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 10.1.12.2 102 broadcast
no frame-relay inverse-arp
!
ip route 0.0.0.0 0.0.0.0 10.1.12.2
R2
hostname R2
interface Serial0/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial0/0.21 point-to-point
ip address 10.1.12.2 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 201
!
interface Serial0/0.23 point-to-point
ip address 10.1.23.2 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 203
!
router eigrp 23
redistribute static metric 1 1 1 1 1
network 10.1.23.2 0.0.0.0
no auto-summary
!
ip route 10.1.1.0 255.255.255.255 10.1.12.1
ip route 10.1.1.1 255.255.255.255 10.1.12.1
ip route 10.1.1.2 255.255.255.255 10.1.12.1
ip route 10.1.1.3 255.255.255.255 10.1.12.1
R3
hostname R3
Router Eigrp Redistribute Static Friction
interface Serial0/0ip address 10.1.23.3 255.255.255.0
encapsulation frame-relay
Router Eigrp 100 Redistribute Static
frame-relay map ip 10.1.23.2 302 broadcast
no frame-relay inverse-arp
!
router eigrp 23
network 10.1.23.3 0.0.0.0
no auto-summary
!
Ok, so nothing special so far, lets have look at what's in the EIGRP topology table:
R2#sh ip eigrp topology
IP-EIGRP Topology Table for AS(23)/ID(10.1.23.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.1.1.2/32, 1 successors, FD is 2560000256
via Rstatic (2560000256/0)
P 10.1.1.3/32, 1 successors, FD is 2560000256
via Rstatic (2560000256/0)
P 10.1.1.0/32, 1 successors, FD is 2560000256
via Rstatic (2560000256/0)
P 10.1.1.1/32, 1 successors, FD is 2560000256
via Rstatic (2560000256/0)
P 10.1.23.0/24, 1 successors, FD is 2169856
via Connected, Serial0/0.23
R2#sh ip eigrp topology 10.1.1.0/32
IP-EIGRP (AS 23): Topology entry for 10.1.1.0/32
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
Routing Descriptor Blocks:
10.1.12.1, from Rstatic, Send flag is 0x0
Composite metric is (2560000256/0), Route is External
Vector metric:
Minimum bandwidth is 1 Kbit
Total delay is 10 microseconds
Reliability is 1/255
Load is 1/255
Minimum MTU is 1
Hop count is 0
External data:
Originating router is 10.1.23.2 (this system)
AS number of route is 0
External protocol is Static, external metric is 0
Administrator tag is 0 (0x00000000)
This is all normal, static routes redistributed to into EIGRP are external routes..
R3#sh ip route | b Gateway
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D EX 10.1.1.2/32 [170/2560512256] via 10.1.23.2, 00:03:05, Serial0/0
D EX 10.1.1.3/32 [170/2560512256] via 10.1.23.2, 00:03:05, Serial0/0
D EX 10.1.1.0/32 [170/2560512256] via 10.1.23.2, 00:03:05, Serial0/0
D EX 10.1.1.1/32 [170/2560512256] via 10.1.23.2, 00:03:05, Serial0/0
C 10.1.23.0/24 is directly connected, Serial0/0
So as I mentioned earlier we can actually make these static routes appear as internal to EIGRP but to make it happen we need to follow a few rules to make it work:
1) The static routes must use an interface as the next-hop rather than an using the next-hop IP Address:
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#no ip route 10.1.1.0 255.255.255.255 10.1.12.1
R2(config)#ip route 10.1.1.0 255.255.255.255 s0/0.21
R2(config)#no ip route 10.1.1.1 255.255.255.255 10.1.12.1
R2(config)#ip route 10.1.1.1 255.255.255.255 s0/0.21
R2(config)#no ip route 10.1.1.2 255.255.255.255 10.1.12.1
R2(config)#ip route 10.1.1.2 255.255.255.255 s0/0.21
R2(config)#no ip route 10.1.1.3 255.255.255.255 10.1.12.1
R2(config)#ip route 10.1.1.3 255.255.255.255 s0/0.21
Update: 31 March 2012 - Tom Kacprzynski rightly informed me that step 2 is not actually required at all for this procedure to work. Thanks Tom!
3) Include the networks of the static routes into EIGRP
R2(config-router)#network 10.1.1.0 0.0.0.3
R2(config-router)#end
Now to see what has changed:
R2#show ip route | b Gateway
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 10.1.12.0/24 is directly connected, Serial0/0.21
S 10.1.1.2/32 is directly connected, Serial0/0.21
S 10.1.1.3/32 is directly connected, Serial0/0.21
S 10.1.1.0/32 is directly connected, Serial0/0.21
S 10.1.1.1/32 is directly connected, Serial0/0.21
C 10.1.23.0/24 is directly connected, Serial0/0.23
These are still definitely static routes, what about the EIGRP topology?
R2#sh ip eigrp topology 10.1.1.0/32
IP-EIGRP (AS 23): Topology entry for 10.1.1.0/32
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
Routing Descriptor Blocks:
0.0.0.0, from Rstatic, Send flag is 0x0
Composite metric is (2560000256/0), Route is Internal
Vector metric:
Minimum bandwidth is 1 Kbit
Total delay is 10 microseconds
Reliability is 1/255
Load is 1/255
Minimum MTU is 1
Hop count is 0
It is now showing up as an internal route even though it shows it was redistributed from static, what does our EIGRP peer R3 see?
R3#show ip route | b Gateway
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D 10.1.12.0/24 [90/2681856] via 10.1.23.2, 00:02:55, Serial0/0
D 10.1.1.2/32 [90/2560512256] via 10.1.23.2, 00:02:55, Serial0/0
D 10.1.1.3/32 [90/2560512256] via 10.1.23.2, 00:02:55, Serial0/0
D 10.1.1.0/32 [90/2560512256] via 10.1.23.2, 00:02:55, Serial0/0
D 10.1.1.1/32 [90/2560512256] via 10.1.23.2, 00:02:55, Serial0/0
C 10.1.23.0/24 is directly connected, Serial0/0
R3#sh ip eigrp topology 10.1.1.0/32
IP-EIGRP (AS 23): Topology entry for 10.1.1.0/32
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560512256
Routing Descriptor Blocks:
10.1.23.2 (Serial0/0), from 10.1.23.2, Send flag is 0x0
Composite metric is (2560512256/2560000256), Route is Internal
Vector metric:
Minimum bandwidth is 1 Kbit
Total delay is 20010 microseconds
Reliability is 1/255
Load is 1/255
Minimum MTU is 1
Hop count is 1
Yes, those static routes on R2 appear to R3 as if they are internal EIGRP routes. Actually, we can remove the 'redistribute static' from the EIGRP process as it is no longer required in this instance.
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router eigrp 23
R2(config-router)#no redistribute static
R2(config-router)#end
Strange as it seems, this appears to be a design intent for EIGRP and is documented on Cisco's website about this.
Mututal redistribution is commonly done to fix architectural problems or during company acquisitions. This lab will discuss and demonstrate the configuration and verification of mutual EIGRP and RIP redistribution.
Real World Application & Core Knowledge
If you've completed Lab 10-2 – Configuring Mutual OSPF and RIP Redistribution and Lab 10-3 – Configuring Mutual OSPF and EIGRP Redistribution then you should be no stranger to mutual route redistribution.
If you did not complete the previous labs then to summarize mutual route redistribution up in a pretty little nut shell; mutual route redistribution is the process where two dynamic routing protocols exchange their routes with each other. For example, When you redistribute EIGRP into RIP, all routes in the EIGRP Autonomous System will be injected into the RIP database and show up as regular RIP routes. The same concepts apply to EIGRP when you redistribute RIP into EIGRP, all the routes from RIP will be injected into the EIGRP topology table and advertised through out the autonomous system as an EIGRP External route. These routes are denoted as 'D EX' routes in the routing table.
Mutual route redistribution is a common remedy when companies acquire other companies that use different routing protocols. In such case Company ABC Inc. acquires Company XYZ Inc. however ABC Inc. uses EIGRP and XYZ Inc. uses RIP. After the acquisition, the CTO (Chief Technology Officer) Mandates that there be full network communication between the newly merged companies. In this case you'd need to perform mutual redistribution to ensure ABC Inc. has routes to XYZ's network; vice-versa.
When you configure mutual route redistribution its best practice to specify a static metric. When specifying a metric keep in mind if you have multiple routers performing mutual redistribution you may need to have a higher metric on one router then the other to prevent a routing loop; this is where packets just keep going in circles between the two autonomous systems. It's a safe bet to specify a fairly high metric in a production network to prevent such routes from becoming looped as lower metric routes are preferred.
The original pitch and time correction audio plugin for finely-tuned vocal pitches. Snap mac screen. GSnap is a very powerful tool given that it?s free. All you need is a monophonic input signal (a microphone can be used) and this software can auto-tune the sound. This can be done to a small degree helping you to correct your pitch or you can ramp it up to create a robotic sound.
We do not provide paid / free Hello Darling Movie downloads. We do not offer to watch Hello Darling movie online. Hello Darling Movie Review are added by registered customers. Free wallpapers download of Hello Darling movie, hero, heroine, etc is available in our Gallery section. Full length feature film shot totally in the Midlands of the UK. Excellent cast and very enthusiastic and able Production Team and Crew. Lots of friends pitched in as. Hello darling full movie watch online, free putlocker. Watch Darling Full Movie by TeluguJosh on dailymotion. Darling Full Movie. 3 videos Updated 2 years ago. Sweetheart - Part 11/11. Sweetheart - Part 10/11. Sweetheart - Part 09/11. About Us What's New Help Center Jobs API Become a. Watch your favourite shows from Star Plus, Star World, Life OK, Star Jalsha, Star Vijay, Star Pravah, Asianet, Maa TV & more online on Disney+ Hotstar. Download Darling Darling movie (1977) to your Hungama account. Watch Darling Darling movie full online. Check out full movie Darling Darling download, movies counter, new online movies in Hindi and more latest movies at Hungama. Download Hungama Play app to get access to new unlimited free mp4 movies download, boolywood movies 2019/2018/2017, latest music videos, kids movies, Hungama.
To configure route redistribution you'll use the redistribute command in router configuration mode.
Please review the following command(s) listed below;
Command | Description |
---|---|
redistribute protocol metric {metric info} | This command is executed in router configuration mode of RIP, EIGRP or OSPF to configure the routing process to redistribute routes from a different source into the configured routing process such as static into RIP or RIP into OSPF. It's best practice to specify a metric; when specifying a metric you specify a metric to be used by the routes when they appear in the routing process. For example, RIP uses hop counts, OSPF uses cost and EIGRP uses K Values (bandwidth, load, delay, reliability, mtu) |
The following logical topology shown below is used in this lab;
Lab Prerequisites
- If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start devices; R1, R2, R3, R4, and R5
- Establish a console session with devices R1, R2, R3, R4, and R5 than load the initial configurations provided below by copying the config from the textbox and pasting it into the respected routers console.
!################################################### !# Free CCNA Workbook Lab 10-4 R2 Initial Config # !################################################### ! enable configure terminal ! hostname R2 no ip domain-lookup ! interface Serial0/0 description ### PHYSICAL FRAME RELAY INTERFACE ### encapsulation frame-relay no frame-relay inverse-arp no shut ! interface Serial0/0.221 point-to-point description ### FRAME RELAY LINK TO R1 ### ip address 10.104.12.2 255.255.255.0 frame-relay interface-dlci 221 exit ! interface Serial0/0.223 point-to-point description ### FRAME RELAY LINK TO R3 ### ip address 10.104.23.2 255.255.255.0 frame-relay interface-dlci 223 exit ! router eigrp 10 no auto-summary network 10.104.12.2 0.0.0.0 network 10.104.23.2 0.0.0.0 exit ! line con 0 logging sync no exec-timeout ! end !################################################### !# Free CCNA Workbook Lab 10-4 R4 Initial Config # !################################################### ! enable configure terminal ! hostname R4 no ip domain-lookup ! interface Serial0/0 description ### PHYSICAL FRAME RELAY INTERFACE ### encapsulation frame-relay no frame-relay inverse-arp no shut ! interface Serial0/0.423 point-to-point description ### FRAME RELAY LINK TO R3 ### ip address 172.29.34.4 255.255.255.0 frame-relay interface-dlci 423 exit ! interface Serial0/0.425 point-to-point description ### FRAME RELAY LINK TO R5 ### ip address 172.29.45.4 255.255.255.0 frame-relay interface-dlci 425 exit ! router rip version 2 no auto-summary network 172.29.0.0 exit ! line con 0 logging sync no exec-timeout ! end<li>configure r3 to redistribute eigrp routes into rip using a hop count of 3 then redistribute rip routes into eigrp using a t1 bandwidth and 20,000 microsecond delay.</li><li>verify on r1 and r5 that routes from the opposite autonomous system exist in their routing table.</li></ul><h2>lab instruction</h2><p>objective 1. – create four new loopback interfaces on r1 using the 10.1.0.0/22 address allocation and configure those interfaces to participate in eigrp autonomous system 10.</p><p>objective 2. – create four new loopback interfaces on r5 using the 172.5.0.0/22 address allocation and configure those interfaces to participate in rip.</p><p>objective 3. – analyze r3's routing table and verify that the newly created loopback interfaces are being learned by r3.</p><p>objective 4. – configure r3 to redistribute eigrp routes into rip using a hop count of 3 then redistribute rip routes into eigrp using a t1 bandwidth and 20,000 microsecond delay.</p><p>objective 5. – verify on r1 and r5 that routes from the opposite autonomous system exist in their routing table.</p><p>you can see from r1's routing table shown above that the rip routes redistributed into eigrp at r3 are being propagated throughout the eigrp autonomous system as eigrp external routes.</p><p>you can see from r5's routing table shown above that the eigrp routes redistributed into rip at r3 are now rip routes on r5 with a metric of 4 (1 hop to r4 + 3 from r3's added metric)</p> readonly=' '=''>